117 lines
4.1 KiB
Nix
117 lines
4.1 KiB
Nix
# Edit this configuration file to define what should be installed on
|
|
# your system. Help is available in the configuration.nix(5) man page, on
|
|
# https://search.nixos.org/options and in the NixOS manual (`nixos-help`).
|
|
|
|
{ config, lib, pkgs, ... }:
|
|
|
|
{
|
|
imports =
|
|
[
|
|
./hardware-configuration.nix
|
|
/var/src/modules/nixin.nix
|
|
/var/src/modules/users.nix
|
|
/var/src/modules/wireguard-client.nix
|
|
];
|
|
|
|
hardware.sensor.hddtemp.enable = true;
|
|
|
|
# Use the systemd-boot EFI boot loader.
|
|
boot.loader.systemd-boot.enable = true;
|
|
boot.loader.systemd-boot.configurationLimit = 7;
|
|
boot.loader.efi.canTouchEfiVariables = true;
|
|
|
|
networking = {
|
|
hostName = "dromadaire"; # Define your hostname.
|
|
# Pick only one of the below networking options.
|
|
# networking.wireless.enable = true; # Enables wireless support via wpa_supplicant.
|
|
# networking.networkmanager.enable = true; # Easiest to use and most distros use this by default.
|
|
interfaces.enp2s0.ipv4.addresses = [ {
|
|
address = "192.168.36.6";
|
|
prefixLength = 24;
|
|
} ];
|
|
defaultGateway = "192.168.36.1";
|
|
};
|
|
|
|
nixin.wg.client = {
|
|
ipv4 = "192.168.12.3/32";
|
|
ipv6 = "2a01:4f9:1a:9a05::3/128";
|
|
};
|
|
|
|
console = {
|
|
font = "Lat2-Terminus16";
|
|
keyMap = "fr";
|
|
#useXkbConfig = true; # use xkb.options in tty.
|
|
};
|
|
|
|
environment.systemPackages = with pkgs; [
|
|
memtester
|
|
# Useful podman development tools
|
|
#dive # look into docker image layers
|
|
podman-tui # status of containers in the terminal
|
|
#aardvark-dns
|
|
#docker-compose # start group of containers for dev
|
|
#podman-compose # start group of containers for dev
|
|
];
|
|
|
|
# Some programs need SUID wrappers, can be configured further or are
|
|
# started in user sessions.
|
|
|
|
virtualisation.containers.enable = true;
|
|
virtualisation.podman = {
|
|
enable = true;
|
|
|
|
# Create a `docker` alias for podman, to use it as a drop-in replacement
|
|
dockerCompat = true;
|
|
|
|
# Required for containers under podman-compose to be able to talk to each other.
|
|
defaultNetwork.settings.dns_enabled = true;
|
|
};
|
|
|
|
services.gitea-actions-runner = {
|
|
package = pkgs.forgejo-runner;
|
|
instances.default = {
|
|
enable = false;
|
|
name = "dromadaire";
|
|
url = "https://git.distrilab.fr";
|
|
# Obtaining the path to the runner token file may differ
|
|
tokenFile = "/etc/forgejo/runner.token";
|
|
labels = [
|
|
# provide a debian base with nodejs for actions
|
|
"debian-latest:docker://node:20-bookworm"
|
|
# fake the ubuntu name, because node provides no ubuntu builds
|
|
"ubuntu-latest:docker://node:20-bookworm"
|
|
# nixos
|
|
"nixos:docker://nixos/nix:latest"
|
|
# provide native execution on the host
|
|
#"native:host"
|
|
];
|
|
};
|
|
};
|
|
|
|
# Open ports in the firewall.
|
|
networking.firewall.allowedTCPPorts = [ 80 144 443 ];
|
|
networking.firewall.allowedUDPPorts = [ 53 ];
|
|
# Or disable the firewall altogether.
|
|
# networking.firewall.enable = false;
|
|
|
|
# This option defines the first version of NixOS you have installed on this particular machine,
|
|
# and is used to maintain compatibility with application data (e.g. databases) created on older NixOS versions.
|
|
#
|
|
# Most users should NEVER change this value after the initial install, for any reason,
|
|
# even if you've upgraded your system to a new NixOS release.
|
|
#
|
|
# This value does NOT affect the Nixpkgs version your packages and OS are pulled from,
|
|
# so changing it will NOT upgrade your system - see https://nixos.org/manual/nixos/stable/#sec-upgrading for how
|
|
# to actually do that.
|
|
#
|
|
# This value being lower than the current NixOS release does NOT mean your system is
|
|
# out of date, out of support, or vulnerable.
|
|
#
|
|
# Do NOT change this value unless you have manually inspected all the changes it would make to your configuration,
|
|
# and migrated your data accordingly.
|
|
#
|
|
# For more information, see `man configuration.nix` or https://nixos.org/manual/nixos/stable/options#opt-system.stateVersion .
|
|
system.stateVersion = "24.05"; # Did you read the comment?
|
|
|
|
}
|
|
|