64 lines
1.4 KiB
Nix
64 lines
1.4 KiB
Nix
# Nixin common configuration for all servers
|
|
{ config, pkgs, lib, ... }:
|
|
{
|
|
# Set NIX_PATH to use nixpkgs deployed with krops
|
|
environment.variables.NIX_PATH = lib.mkForce "/var/src";
|
|
|
|
networking = {
|
|
nameservers = [ "80.67.169.12" "80.67.169.40" "2001:910:800::12" "2001:910:800::40" ];
|
|
enableIPv6 = true;
|
|
};
|
|
|
|
environment.shellAliases = {
|
|
tm = "tmux new -A -s shared" ;
|
|
ll = "ls -al";
|
|
};
|
|
|
|
# Enable the OpenSSH daemon.
|
|
services.openssh.enable = true;
|
|
services.openssh.ports = [ 144 ];
|
|
services.openssh.settings = {
|
|
PermitRootLogin = "no";
|
|
PasswordAuthentication = false;
|
|
KbdInteractiveAuthentication = false;
|
|
};
|
|
|
|
# Set your time zone.
|
|
time.timeZone = "Etc/UTC";
|
|
|
|
# Select internationalisation properties.
|
|
i18n.defaultLocale = "en_US.UTF-8";
|
|
|
|
i18n.extraLocaleSettings = {
|
|
LC_ADDRESS = "en_US.UTF-8";
|
|
LC_IDENTIFICATION = "en_US.UTF-8";
|
|
LC_MEASUREMENT = "en_US.UTF-8";
|
|
LC_MONETARY = "en_US.UTF-8";
|
|
LC_NAME = "en_US.UTF-8";
|
|
LC_NUMERIC = "en_US.UTF-8";
|
|
LC_PAPER = "en_US.UTF-8";
|
|
LC_TELEPHONE = "en_US.UTF-8";
|
|
LC_TIME = "en_US.UTF-8";
|
|
LANGUAGE = "en_US.UTF-8";
|
|
LC_ALL = "en_US.UTF-8";
|
|
LC_CTYPE = "en_US.UTF-8";
|
|
LC_COLLATE = "en_US.UTF-8";
|
|
LC_MESSAGES = "en_US.UTF-8";
|
|
};
|
|
|
|
environment.systemPackages = with pkgs; [
|
|
git
|
|
wget
|
|
tmux
|
|
htop
|
|
mosh
|
|
dig
|
|
];
|
|
|
|
programs.neovim = {
|
|
enable = true;
|
|
viAlias = true;
|
|
vimAlias = true;
|
|
};
|
|
|
|
}
|