nixin-krops/modules/users.nix

27 lines
813 B
Nix

# Admin users
{ config, pkgs, ... }:
{
# Define user accounts. Don't forget to set a password with 'passwd'.
users.users.douzeb = {
isNormalUser = true;
description = "douze baie";
extraGroups = [ "wheel" ];
packages = with pkgs; [];
openssh.authorizedKeys.keys = [
"ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAILRG0CyeeMMrrjTTm/PHgRXD/I4lH/bBPBCGUiL+cBdq douzeb@tux-12"
];
};
users.users.mrflos = {
isNormalUser = true;
description = "mr flos";
extraGroups = [ "wheel" ];
packages = with pkgs; [];
openssh.authorizedKeys.keys = [
"ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIBBM+2TwkopAQF7splTWjORQoxjcp67VhodwzvTMlL8g florian@florian-LinuxMint-MBP"
];
};
# Passwordless sudo for members of the wheel group
security.sudo.wheelNeedsPassword = false;
}